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HYPACK SHELL

• Users can now add S-102 (*.h5) charts as background files in a project.
> S-102 charts can be exported to XYZ and GeoTIFF files using the right click menu.
> The Info Query tool can be used on S-102 files.
> S-102 charts work similarly in HYPACK Survey and loads as background charts in the 

editors and MBMAX64.
• Users can now add custom labels to each band in a color table (*.hcf file), and also 

choose to display those labels on a color bar in the HYPACK Shell. 
> To add custom labels, open the Color Table Editor (HYPACK Shell -> Sounding 

Colors tab -> [Edit Color Table], right click on the desired color band and click Set 
Label. Type in the label name, then click [OK]. Once you are finished adding labels to 
all the color bands you need, click [Apply] and then [OK].

> To display those custom labels, back in the HYPACK Shell, right click on the color 
bar and click Show Label.

• User-defined buttons or tools can now be added to custom toolbars. The Customize 
dialog used for toolbar customization now includes the User Tools Category, where any 
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user-defined buttons are listed and can be added to the toolbar. These user-defined 
buttons are used to launch external executable files.

To create a user-defined button or tool to launch an external program from HYPACK:

1. From the HYPACK Shell, click Tools -> Setup to open the Tool Options window.
2. In the Tool Options window, click [Add] to open the Tool Properties window.
3. In the Tool Properties window, fill out the program's name, select the executable file from 

your device, and enter any parameters that need to be passed to the executable on 
initialization. Click [OK] in Tool Properties, then [Close] in the Tool Options.

The new user-defined tool can be accessed from the Tools menu.

To add the user-defined button to a customized toolbar:

1. From the HYPACK Shell, right click on the top toolbar -> Customize to open the 
Customize window.

2. In the Commands tab, click User Tools under the Categories list on the left. All user-
defined tools will be listed in the Commands list on the right.

3. Click the user-defined tool and drag and drop it in the custom toolbar of your choice. The 
user-defined tool name will appear in the custom toolbar.

• TIN files created in the TIN Model program can now be displayed in the main area 
map in the HYPACK Shell. They are accessed in the Project Items tab in the Project 
Files -> Background Files folder. 

You can also change how the TIN model drawing style by right clicking on the file -> 
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Style, and clicking Points, Hollow, or Filled.

The following images show examples of the display if Points (left), Hollow (center), or 
Filled (right) are selected.

• Removed the View Log Window menu item from the File menu in HYPACK Shell. 
This was an unmaintained window and did not show useful information to the user. The 
following images show the File menu before (left) and after (right) the removal the View 
Log Window option.

• In the Project Items list, the right-click menu options have been reorganized to 
group related items. Some items were also moved to the Options menu drop down to 
reduce the volume of options in right-click pop up menu.
4



The following images are examples of what the right-click menu looks like before (left) 
and after (right) the update.

• Added the options Export to XYZ and Export to MTX to the right-click menu for 
ESRI TIF files. Access the menu from Project Items list in the HYPACK Shell.

> If Export to XYZ is selected, the Save As window appears. Give the XYZ file a name 
and click [Save]. The file is saved to the Sort folder by default.

> If Export to MTX is selected, the Save As window appears. Give the MTX file a name 
and click [Save]. The file is saved to the project folder by default.

• Added yards to the list of selectable units in the units drop down of the Measure 
Tool.
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To use this new feature, in the HYPACK Shell, click the Measure tool on the right toolbar.
The distance and azimuth toolbar appears at the bottom of the Map window. Click the 
units drop down and select yards.
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• If your HYPACK license is deactivated or otherwise not detected, the “No License 
Found” popup now appears upon program startup. This update is intended to help 
users who regularly use their HYPACK® license on multiple devices.

• “No Project Loaded” is also displayed on the title bar of the HYPACK Shell after 
closing a project of if a project failed to load during startup. No Project Loaded is 
also displayed if HYPACK cannot find hypack.ini, or if the project location was changed.
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• Clicking [Add ENC Charts] in the HYPACK Shell now launches a confirmation 
dialog that displays the number of charts to be downloaded. 

Click [OK] to download all charts, or [Cancel] to prevent the operation. Previously, clicking 
on [Add ENC Charts] would immediately begin the download of all charts available in the 
area displayed in the map window, and if the view was zoomed out enough, it is possible 
to end up downloading hundreds of charts with no way to cancel the command. This 
update gives users the opportunity to prevent the automatic download of hundreds of 
charts that they might not need or want. 

PREPARATION

BACKGROUND CHARTS

OPENSTREETMAPS

• All projects now automatically contain a Dynamic OpenStreetMaps file within the 
Background Files folder. When checked, OpenStreetMaps is automatically 
displayed (sometimes with a slight delay) in the map view of the HYPACK Shell. 
Zooming in and out with the mouse scroll wheel or zoom functions in HYPACK Shell will 
pull in additional maps to display. This file is stored on your device at C:\HYPACK 
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2024\Projects\Project Name\Dynamic OpenStreetMaps.

In addition to the HYPACK Shell, OpenStreetMaps can be enabled and displayed within 
other HYPACK programs including HYPACK SURVEY, HYPLOT, and editors. The below 
examples show the OpenStreetMaps chart within MBMAX64 (top) and HYPLOT MAX 
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(bottom).

• We've added the Explore OpenStreetMaps widget, which allows users to export 
part of the OpenStreetMaps as a *.tif file for use as a background chart.
10



To use this new feature, from the HYPACK Shell click Widgets -> Explore 
OpenStreetMaps to open the Custom Map dialog.

Select the map source (currently OpenStreetMaps is the only one available), enter the 
location using X/Y or Lat/Long coordinates, then click [Search Location]. You can zoom in 
and out using the mouse scroll wheel or the slider at the bottom of the window. Click 
[Export Map], then give your file a name. The file is saved in the project folder by default.
February / 2025  11



Back in the HYPACK Shell in the Project Items tab, click Options and select Rescan 
Folders. The new OpenStreetMaps chart should appear in Background Files, where you 
can enable to display in the map view.

GEODETIC PARAMETERS

• The Datum Shift File field in the Geodetic Parameters dialog has been changed to a 
dropdown list that contains only valid datum shift files (*.lls and *.gsb).
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GEODETIC LIST CONVERSION

• In the Geodetic List Conversion Program, three depth inversion options have been 
added to the Other drop down menu:
> Invert and Meters to Feet - Invert depths and convert units from meters to feet (ex: m 

to -ft).
> Invert and Feet to Meters - Invert depths and convert units from feet to meters (ex: ft 

to -m).
> Invert Depth - Invert depths only (ex: d to -d).

To use these options, from the HYPACK Shell click Utilities -> Geodesy -> Geodetic 
List Conversion to open the Geodetic List Conversion dialog.

In the following example, Invert Feet to Meters is selected, and the depth value from 
the input file (50.40 ft) is inverted and converted to meters (-15.36 m) in the output file.

HARDWARE

SURVEY DEVICE DRIVER UPDATES

• Gps.dll: Added the “Ignore ZDA Date” option in the Advanced device settings to 
overwrite the ZDA string date with the PC/computer date. This option was added to 
support end of life GPS units that are experiencing GPS week number rollover (WNRO) 
issues.

Please note that unless specifically instructed by the HYPACK Technical Support Team, 
leave this option unchecked.

To use this new feature:
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1. From the HYPACK Shell, click Preparation -> Hardware Setup.  The HYPACK Combined 
Hardware window appears.

2. Add the gps.dll driver, then double click on the GPS NMEA-0183 driver to open the Setup 
window.

3. In the Setup window, click [Advanced]. The Advanced options window appears.
4. Check Ignore ZDA Date, then click [OK].

• POSMV.dll: 
We’ve added the capability to use Group 1 codes back to the driver setup with the 
new frame data options. We recommend selecting Group 102, which logs multibeam 
frame data. Selecting Group 1 records vessel frame data, and we recommend using this 
14



option only if Group 102 is unavailable.

To select the Frame data source:
1. From the HYPACK Shell, click Preparation -> Hardware Setup to open the HYPACK 

Combined Hardware window.
2. Select posmv.dll from the Available drivers list, then click [Add -->].
3. Double click on the Applanix POS M/V driver from the Installed list. The Applanix POS M/

V Setup window appears.
4. Select your options. Under Frame data, choose between Group 102 and Group 1, then 

click [OK].

• Cutfill.dll: Added a drop-down box in the cutfill.dll Setup dialog to select the tide 

source, which users can designate either the global tide from HYPACK® SURVEY 
or a specific mobile as the tide source.

The mobiles listed under the Tide Source dropdown will depend on what is added in the 
HYPACK Combined Hardware. In this example, you can select from Dredge, Arm, and 
Spud, which correspond with the mobiles that are added in the following HYPACK 
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Combined Hardware image.

Note that Tide Source interacts with the Individual Tide Per Mobile checkbox in the 
HYPACK Survey options in the System tab at the Hardware level. Individual Tide per 
Mobile enables you to use multiple tide devices - up to one for each mobile in your 
configuration. When this option is checked, any mobile without a tide device assigned to it 
will inherit the tide of the main vessel.

So, if Individual Tide Per Mobile is checked:
> If Global is selected in Tide Source, the Cut Fill Monitor window will display the tide 

from the mobile on which the device is installed.
> If a mobile is selected and it has a tide device, then the tide reading from that device 

will be used.
If Individual Tide Per Mobile is unchecked:
> If Global is selected, the Cut Fill Monitor window will display the global tide from 

Survey.

To use the Tide Source option:
1. Add your mobile, give it a name in the Mobile Name field, and click File -> Save. 

This adds the name of the mobile to the Tide Source drop down in the CutFill driver Setup 
window.

2. Add the tide device(s) to each mobile that has one.
3. Add cutfill.dll to the appropriate mobile.
4. Double click on the Cut Fill Monitor driver to open the Setup dialog, then pick your Tide 

source and click [OK].

• Subbot.dll: Added support for the GeoAcoustics GeoPulse Compact sub-bottom 
sonar. To use this device in HYPACK, in the HYPACK Combined Hardware add 
subbot.dll (Sub-bottom Driver) to your vessel, then in the Setup window, select 
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GeoAcoustics GeoPulse from the Devices list as shown on the left. Then, go to the 
Survey Device tab, then configure the Connection Type as shown on the right.

For additional information, refer to GeoAcoustics GeoPulse Compact Support Added to 
HYPACK by Daniel Tobin.

• Aistide.dll: Driver now reads VDM and VDO messages.

• New Driver: Optimal Ranging Orion (Orion2.dll)
This driver is largely identical to the Orion.dll driver and was created for a specific use 
case that may not be relevant to all users. This driver uses the Orion ROV's position, 
depth, and heading to calculate the position and depth of burial of a target cable. The 
measured depth can then be corrected in SBMAX using altitude data from an altimeter. 
The following is a list of where the drivers differ:
> The Orion2 driver additionally reports position, depth, and heading. This driver uses 

the USBL position and depth as a starting point, then uses the current offset from the 
device to obtain its position and depth. The heading can be configured to come from 
the Orion device itself or from the USBL.

> To work properly, this driver requires an altimeter and must be on its own mobile with 
a gendevparse.dll driver reading heave from the altimeter. The Orion2 driver should 
be set relative to another ROV mobile which handles the position of the device itself.

> The heave and depth data should be used in SBMAX to calculate the depth of burial 
of a target cable.
February / 2025  17



> The following setup parameters allow the data to be easily read by SBMAX:

• DQM Mechanical Driver (DQM_Mechanical.dll)
The DQM Mechanical Driver has received a few updates:
> Added CD17 Système to the DQM_Mechanical driver, which acts as a ModBus 

master to obtain crane slew, boom angle, and wire length from the sheave. 
Select this option if you have a ModBus-connected PLC crane. Note that the 
modbus.dll needs to be added to the HYPACK 2024 root directory to support the 
18



ModBus connection.

To use this feature:
1) From the HYPACK Shell, click Preparation -> Hardware Setup to open the 
HYPACK Combined Hardware window.
2) Add the DQM Mechanical Driver, and double click it to open the Settings window.
3) Under the System Type drop down menu, select CD17 Système. The CD17 
Système tab appears.
4) Under the CD17 Système tab, fill out the IP address of the PLC crane, the ModBus 
port number, and the holding register offset.

> The Design Profiles tab in the DQM Mechanical Driver device window now 
allows users to add up to 10 extra profile lines.
To navigate to this tab, first add and set up DQM_Mechanical.dll in HYPACK 
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Combined Hardware. Run DREDGEPACK®, and the DQM Mechanical Driver device 
window appears, which will have the Design Profiles tab.

• Enable the profile lines by checking each box that corresponds to the line you 
want to display.

• Under Type, select Design or Survey, which specifies the profile you want to 
replicate.

• Offset is the distance from the original profile.
• Customize the appearance each profile line with width (line weight in pixels), color 

of the profile line, and line style.

• MAVLink (mavlink.dll)
The MAVLink driver setup window has been completely reworked - The Upload Mission 
and Download Mission buttons have been replaced with a dropdown to select the 
manufacturer. The current manufacturer options are Generic and Seafloor USV.

This change was made because both Upload and Download Mission buttons are now 
redundant, as we upload the current Survey line file to the device when you click the 
[Start Mission] button in Survey. The Download Mission button could have some utility if 
you were trying to transfer Survey line plans using your vessel, but there are better ways 
to do that and limited use cases.
For more information about the MAVLink driver update, check out the article MAVLINK 
Autopilot Updates by Daniel Tobin, published October 2024.

Before After
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• New Driver: MAVLink v2 (MAVLink v2.dll)
This new driver was created to support v2 of the MAVLink interface. It uses mostly 
the same code as v1, but swaps out the v1 MAVLink API for v2.
Note: We are currently keeping the previous v1 MAVLink driver. 
The MAVLink v2 setup window currently only supports the Spatialnetics Offboard 
Autopilot software.

To use: 
Launch the Offboard Autopilot.exe. Add the MAVLink v2 driver to the HYPACK Combined 
Hardware. In the Offboard Autopilot settings, configure it to be a TCP connection, client 
address is 127.0.0.1, IP is 14550.
Launch HYPACK Survey. Offboard Autopilot should display “MAVLink Connected” at the 
bottom, indicating a successful connection.

• Trackpoint II ROV Acoustic System (trackp.dll)
In the Trackpoint Setup window, Target Number has been updated to Beacon ID to clarify 
that this value corresponds to the beacon number. Setup and behavior remain the same.

• EchoTrac E20.dll (Teledyne ECHOTRAC E20)
Several updates were made to this driver:
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> Users can now choose what data to display on event marks from the EchoTrac 
E20 setup window in the Annotation Options section.

To customize the event marks, from the HYPACK Shell open HYPACK Combined 
Hardware, add the ECHOTRAC E20.dll driver, and double click its name to open the 
EchoTrac E20 setup window. From the Annotation Options section, select None, 
Standard, or Special and check the data values you want to display.

Choose from the following data values when Special is selected: 
Event, Line Name, DMG, XTE, DEP 1, DEP 2, Heave, Draft, X, Y, LAT, LON.

> Draft can now be added as an annotation value.
> The output now displays the values for Depth, Heave, and Draft to two decimal 

places.

• spectre.dll (Dynautics Spectre)
A few updates were made to the driver and the Dynautics Spectre runtime window in 
HYPACK SURVEY:
> Control now defaults to Dual mode upon startup so autopilot will always accept 

HYPACK commands from the beginning.
> UDP connection setup was added.
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> When a track is uploaded, Track mode is no longer automatically forced.

HYSWEEP® DEVICE DRIVER UPDATES

• Previously, HYPACK supported SEA Bathyswath and SEA SWATHplus. These 
devices have been consolidated into one, which is now named ITER Systems 
Bathyswath.

• The PingDSP driver format method in the Device Setup window now defaults to 
Binned instead of Raw. Here are the differences between the two formats:
> Raw - Provides noisy data that is subsequently run through HYSWEEP interferometry 

filters and processing. Not recommended.
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> Binned- Uses PingDSP binning methods to provide multibeam-style data that should 
need no additional processing by HYSWEEP. This update was made to help users 
collect data in a desirable format.

DREDGEPACK®DEVICE DRIVER UPDATES

• Mobileconnect.dll: The Mobile Connect window has been updated with color and 
transparency selections for the outline and fill of the mobile connect arm. Users can 
also specify the start and end width of the connection.

The Mobile Connect driver was developed to connect the trunnion (origin point) on a 

dredge to the cutter head in the DREDGEPACK® map display to illustrate the physical 
connection and changing length of the ladder as it moves.

To use these new features:
1. In HYPACK Hardware, add the mobileconnect.dll to the dredge mobile.
2. In the HYPACK Shell, Open Survey -> DREDGEPACK. The HYPACK Mobile Connect 

window appears.
3. For the outline of the arm, you can adjust the width (0 to 10 pixels wide), color (custom or 

preset), and transparency.
4. Check the Solid Fill box to apply a fill to the inside of the arm. You can adjust the color 

(custom or preset) and transparency of the fill.
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5. At the bottom of the window, adjust the width of the start (trunnion/origin point) and end 
(cutter head) of the mobile connect arm by typing in a number or using the up and down 
arrows.
The following image is an example that shows the settings in the Mobile Connect window 
and the corresponding dredge arm.

• Excavator.dll: Added the Smooth Channel Option, which when enabled calculates 
and draws straight line segments instead of a step-like line for the channel’s slope.
To use this new feature, in the HYPACK Hardware add excavator.dll. Open the device 
driver setup window, then click on the Profile/Shapes tab and check the Smooth Channel 
box.
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The example below shows the Excavator interface with the Smooth Channel option 
unchecked (left) and checked (right).

• HopperDQMSender.dll:
Added the Pass-through Mode checkbox in the HopperDQMSender driver setup 
window. When this box is checked, this mode will look for data via serial or network, and 
if it receives something, will verify that the data is valid, add the Plant ID to the XML, and 
send the data via DQM Direct. The status and data tabs will not be visible on the runtime 
window. The user will only see the outgoing string, the time of the last message received, 
and the result of the DQM Direct send.

• EntekTSHD.dll (Entek Hopper System)
26



> Added two settings to the Entek Hopper System Device Settings window: Fwd 
Draft Sensor To Mark, and Aft Draft Sensor To Mark. These settings are for 
entering the values of the distance from the bubblers to the aft and forward marks. 

> Entek TSHD runtime window now shows the location of both of these marks as 
an 'X'.

> The Aft Draft and Fwd Draft values in the runtime window correspond to the aft 
and forward marks.
The following image shows an example runtime window for the EntekTSHD driver. 
Notice that the Aft Draft value is 4.8, and the Fwd Draft value is 11.5, which 
correspond to the 'X' marks in the graph below.
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INPUT ECHO

The Input Echo dialog has received multiple updates.

• Users can now add and remove up to eight outputs using the newly added [Add Output] 
and [Remove Output] buttons.
> The supported output connection options are serial port, parallel port, and network 

port. Additionally, the output data can also be saved to file(s).
> If the wrong device is removed, click [Add Output] to add back the most recent 

deleted device.
• The supported input port types are serial port, parallel port, and network port.
• Parameters change depending on the input or output connection type selected.
• When File is selected as the output connection type, check the Split Files checkbox to 

split the data into multiple files based on size. This prevents giant files from being 
created. Additional files will be saved in the format {FileName}_{number}.extension (Ex: 
test.tmp, test_1.tmp, test_2.tmp, etc.).

• Settings are saved when Input Echo is closed.

TARGETS

TARGET EDITOR

• Klein Spectral AI targets can now be imported in the Target Editor.

To use this new function:
1. From the HYPACK Shell, click Preparation -> Editors -> Target Editor. The Target Editor 

window appears.
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2. In the Target Editor window, click File -> Import -> Klein Spectral AI. The Import Target 
File window appears.

• Select one or multiple Klein Spectral AI target files and click [Open]. Only JSON files can 
be selected. The associated TIF file will also be imported as well.

Back in the Target Editor, the selected Klein Spectral AI targets will appear in the list of 
targets on the left. Name and metadata read from the JSON file of the associated target 
will be displayed on the right, as well as the TIF image.

SURVEY

• Users can now convert *.mxb to *.mtx files directly in HYPACK® SURVEY and 

DREDGEPACK®. *.mxb files are backup binary versions of the matrix files created at 
user-defined time intervals while surveying. These *.mxb files can be used to restore your 
project *.mtx file to the state it was at the time the file was generated, which ensures 
security against data loss.

To use this new feature, in HYPACK® SURVEY or DREDGEPACK®, click on the Matrix 
tab in the toolbar and click Convert .mxb -> .mtx, and the Open dialog appears. 

In the Open dialog, click on the *.mxb file and click [Open]. In the Save As window, give 
your *.mtx file a name, then click [Save]. A new matrix file will be loaded and drawn on the 
map, and you can continue with your surveying.

For additional information, refer to Converting MXB Files to MTX in DREDGEPACK® by 
Jocelyn Kane.

• Fixed a bug where customized toolbar settings in the Survey window were not 
saved after closing Survey. Replaced both Toolbar menu options (Main Form and Map 
Windows) with the built-in toolbar customization window. Selecting these menu items will 
popup the customize dialog, where different sub-toolbars can be turned on and off.

To customize and turn toolbars on and off in the main Survey window, click Window 
-> Toolbox, and the Customize window opens. From the Toolbars tab, you can enable 
and disable toolbars, create new toolbars, rename and delete custom toolbars, and reset 
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the default toolbars. To add more features to a toolbar, navigate to the Commands tab, 
and click, drag, and drop each command icon at the desired location on the toolbar. To 
remove a tool from the toolbar, while the Customize window is open, click and drag the 
icon off the toolbar.

To enable and disable toolbars in the area map window, right click on the grey toolbar 
and click on the name of the tools or toolbar you want to add or remove. To customize 
toolbars in the area map window, click Customize, and the same Customize window 
described previously appears.
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Tip: When you are dragging a tool from the Commands box to the toolbar, make sure the 
insert indicator appears - the tool you are dragging will be placed in that position.

LEFT/RIGHT INDICATOR WINDOW

• Users can now change the style and weight of the indicator arrow in the Left/Right 
Indicator window. To do this, in the Left/Right Indicator window click Options -> 
Indicator, and select between Arrow or Bar, as well as the weight (Thin, Medium, Heavy).

The following images show the Arrow (top) and Bar (bottom) styles, as well as the weight 
February / 2025  31



(left to right is Thin, Medium, Heavy).

HYSWEEP SURVEY
• Added an altitude window to HYSWEEP, similar to what is found in side scan 

survey, which takes the device reported altitude and displays this output in its own 
window. For additional information, refer to the article Altitude Window for Side Scan 
Sonars in HYSWEEP® by Andrew Clos.

• Added the Dredge Mode option to the Matrix Options window in HYSWEEP Survey. 
Enable Dredge Mode if the vessel is stationary (dredge conditions). This fills the real time 
matrix with values that have applied offsets appropriate to a stationary dredge as 
opposed to a moving survey boat. Soundings are filtered via signal strength and 
collinearity to determine and select the highest quality soundings for use in the matrix.

With Dredge Mode enabled, roll, pitch, and non-averaged tide corrections are 
automatically applied to the matrix values, but not heave. While Dredge Mode is enabled, 
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the Draw Matrix in HYPACK Survey option is permanently enabled as well.

To use this new option:
In the HYSWEEP Survey window, click Options to open the Matrix Options window and 
check Dredge Mode. A couple of things will happen.
The title bar of "HYSWEEP Survey" will be replaced with "HYSWEEP Dredge Mode".

The View Options window (HYSWEEP View -> Options -> Other tab) will also 
permanently enable the Apply Heave, Pitch, Roll Corrections and the Apply Tide 
Correction options while Dredge Mode is selected.
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• Added the Invert Depths option to the Matrix Options menu, which inverts the 
depth values going into the matrix. This is for users who need an elevation matrix/
elevation mode.

• In the View Options dialog, when Auto Scale Profile is checked, the minimum depth 
value (z-axis) is now automatically updated for the Sweep Profile and the Sounding 
Points options. Note that the minimum depth value remains locked at zero for the Beam 
Pattern and Wavefront options.

To use this feature:
1. In HYSWEEP Survey, click View -> Options. The View Options dialog appears.
• In the Multibeam Display tab, check Auto Scale Profile, select either Sweep Profile or 

Sounding Points, and click [Apply].
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You will see that the minimum depth value automatically adjusts to a more suitable value 
in both the Ranges tab of the View Options dialog, as well as the Profile Window.

REAL TIME CLOUD

• Added option to display the water column data in Real Time Cloud. To enable check 
the option on the Settings dialog. To set coloring change the color table used for the 
intensity colors (cloudInt.hcf by default).

• Users can now modify target size and style in the Real Time Cloud program.

To use this new feature, first launch HYPACK® SURVEY, then click Options -> Shared 
Memory -> HYPACK Real Time Cloud. In the Real Time Cloud window, click View -> 
Settings to open the Settings dialog. In the Targets drop down menu, select from the 
following options: None, Point, Circle, Cylinder, MBMAX64, and Flag. You can also adjust 
the size of the targets from the Size field.
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As a reminder, here are how the target styles appear. From left to right, top to bottom, the 
target styles used are Point, Flag, Circle, Cylinder, and MBMAX64.

POST-PROCESSING

64-BIT SINGLE BEAM EDITOR (SBMAX64)
• We made a number of updates and bugfixes to the Offline Statistics window:
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> Added the Depth 1 and Depth 2 check boxes to choose either or both depths.

> The number of points sometimes wrote on top of “Number of Points”, this has been 
fixed.

> Fix wrong line in graph being used to determine where to print max points.
> Updated start line to use in calculations every time data changes, so switching 

between Current Line and All Lines now updates correctly.
> Catch when line is changed in editor file list and update calculations.

• Added the Hide Deleted checkbox to the Spreadsheet window, which hides deleted 
soundings when checked. The first image below shows deleted soundings in the 
Spreadsheet window while Hide Deleted is unchecked, and the following image shows 
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the spreadsheet with deleted soundings removed after Hide Deleted is checked.

• The tide displayed in Tide Analyzer now matches with the Tide shown in the Heave/
Tide/Draft Editor window in SBMAX64. Previously, the tide display was inverted.
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• Added the field Z-Multiplier for XYZ to the Save Survey window. Users can now enter 
a positive or negative value, which will be used as a multiplier with the Z value. For 
instance, enter -1.0 to invert the Z. The default value is 1.0.

To use this function:
1. In SBMAX64, click File -> Save Survey. The Save Survey window appears.
2. Type the multiplier value in the Z-Multiplier for XYZ field.
3. Select one of the save options, and the Save As window appears. Keep in mind the XYZ 

files are saved in the project's Sort folder by default.
4. Give the XYZ file a name and click [Save].
5. Open the XYZ file and verify that the Z multiplier has been applied.

The following example images below show the XYZ values without (left) and with (right) 
the multiplier of -2.0 applied.

• The "All" depth option is selected by default in the Contours window of SBMAX64 
when the SonTek M9 is configured. This update was made since the SonTek M9 is a 
multi-transducer system which collects depth data from dual 4-beam transducers and one 
vertical beam echosounder. Before the update, depth options included Depth 1, Depth 2, 
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and Both, however the issue is that depths 1 and 2 may not be populated with data. 
Beams 1-4 are set to one frequency, and beams 6-9 are set to the other frequency and 
swap depending on the depth. Only beam 5 from the vertical beam echosounder always 
has data. Because of this setup, the "Both" depth option was changed to "All" depths, and 
data from all nine beams are used for sorting and contouring.

ECHOGRAM WINDOW

• The [Export] button in the Echogram window now opens the Export dialog, which 
has additional functionalities.
When users export signal intensity data as ASCII *.txt files, they have the option to 
choose which depth data to export, as well as whether they want to export data 
from the currently displayed line or all lines. Users can now also export screenshots 
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of the echogram as *.jpg files through the SBMAX64 echogram window.

To us these new functions, you will need to first load at least one *.raw file and open the 
data in the echogram.

From the HYPACK Shell click Processing -> Single Beam Editor (64 bit), and the 
SBMAX64 window opens. Click Load Survey, and in the Raw folder select the LOG file 
and click [Open]. Click any of the *.raw files in the Catalog window, then click [Select] or 
[Select All]. In the Read Parameters window, click [OK]. Back in the SBMAX64 window, 
click [Echogram] to open the echogram window(s).

Once in the Echogram window, click [Export]. The new Export window allows users to 
select the File Types (*.txt or *.jpg) they want to generate. If Samples (.TXT) is selected, 
users can further choose if they want to export data for Depth 1, Depth 2, or both, as well 
as whether they want to export data for the current line or all lines. Click [OK], and the 
Select Folder dialog appears. Choose the desired folder to save the exported files, then 
click [Select Folder]. Within each *.txt file, the program exports each sample as a number, 
and data is grouped into rows by ping.

In the following example, both depths are selected and the output files each contain 
intensity data from a single depth channel. File names are in the format of 
RawFileName.RAW_Channel#.txt.
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If you choose Image (.JPG), a different Save dialog will appear. Choose the desired 
location to save the exported image, then click [Save]. The output will be an image 
capture of the graph from the echogram window.

SB SELECTION

• The Sounding Selection program has new sounding selection options: Start Gate, End 
Gate, Include First Point, and Include Last Point.
> Start Gate - Set the starting distance along the line where soundings will start being 

selected. For example, if you do not need the first bit of data because it is too far from 
your trackline, you could set the Start Gate value to 200 m. If left blank, no start gate 
will be used.

> End Gate - Set the distance beyond which no more soundings are selected. If left 
blank, soundings will be selected through the end of the line.

Previously, when selecting by Distance, the Sounding Selection program did not take into 
account the first and last points of the data file. We've added these as options:
> Include First Point - Enable to keep the original starting point of the line.
> Include Last Point - Enable to keep the last very point of the line.
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To use these new options:
1. From the HYPACK Shell, click Processing -> Sounding Selection -> SB Selection. The 

Sounding Selection window opens.
2. On the left toolbar, make sure the Distance checkbox is checked. You can type in values 

for Start Gate and/or End Gate, and check or uncheck the Include First Point and Include 
Last Point boxes.

3. Click [Apply Settings] to apply these settings to your sounding selection.

The following example shows how these new sounding selection options are applied. 
Include First and Include Last Points are enabled, and so both points are selected 
(contrast this with the previous image where these options are not checked). Start Gate 
and End Gate are set to 200 and 850, respectively, and soundings from in between these 
two distances are selected.

REAL-TIME MOSAIC FOR SIDE SCAN DATA

• The Real-Time Side Scan Mosaic Settings dialog has received a slight UI update. 

Users will also receive a warning and are sent back to the Real-Time Side Scan Mosaic 
Settings dialog if the resolution is too low.
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• Bugfix: Previously, changing resolution and clicking “No” when it asks to delete old 
mosaics causes old mosaics to be drawn offset. GeoTIF files are now created at the right 
location.

SIDE SCAN PROCESSING

TARGETING AND MOSAICKING BETA

• The Side Scan Targeting and Mosaicking Beta (SSTM) now supports loading 
backscatter exports from MBMAX64 in the HS2x format. We’ve also added a new 
gain option that works great with backscatter (Angle Varied Gain, across all lines). Refer 
to our article Backscatter Update for Side Scan Targeting and Mosaicking by Daniel 
Tobin for more information.

• The Optimal Resolution Calculator has been greatly simplified to display only two 
fields, Range and Horizontal Aperture in degrees, since these are the only values 
used to calculate the suggested resolution.

To use the new Optimal Resolution Calculator:
1. From the HYPACK Shell, click Side Scan -> Targeting and Mosaicking (Beta). The Side 

Scan Targeting and Mosaicking Beta window appears.
2. Load some data, then click Tools -> Resolution Calculator. The Optimal Resolution 

Calculator window opens.
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Note you can also open the calculator by selecting the Mosaic tab, then clicking on the 
calculator icon under the Lines list.

3. The current dataset's range should be listed. If the dataset's sonar has an entry in our 
database, the Horizontal Aperture field should be accurately filled. Otherwise, it uses the 
default of 0.5.

NOTE: Only the 64-bit version is included. There is no support for the 32-bit version due its 
lower memory limits.

SEGMENTATION AND CONTOURING

New in HYPACK® 2025 is segmentation and contouring in Side Scan Targeting and 
Mosaicking (SSTM). This includes the following features:

• Create binned XYZ files of your data.
> An XYZ file is created at a configurable grid size (say, a 10-foot grid). This is the “bin” 

size.
> In each bin (e.g. each 10x10 foot area) of your mosaic, the X and Y coordinates and 

average signal intensity are written to the XYZ file (the signal intensity is written 
instead of depth).

• Create a DXF segment files using your XYZ files.
> Our TIN engine is leveraged for this.
> Given an XYZ file, adjacent bins with similar intensities are grouped into “segments”.

• Interpret DXFs and label segments.
> The range of intensities a given segment covers is configurable.
> Once you've created a segment, you can label and color that segment.
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For a full breakdown of the Segmentation and Contouring in HYPACK® 2025, refer to the 
article Segmentation in Side Scan Targeting and Mosaicking by Daniel Tobin.

64-BIT HYSWEEP® EDITOR (MBMAX64)
• KMALL and ALL files now calculate RTK tides when loaded into MBMAX64 if an 

RTK method is selected in the RTK Tide Method section of the Geodetic 
Parameters dialog in the HYPACK Shell. If “Not Using RTK Tide” is selected, no 
ellipsoidally-referenced tides are calculated.

• The [Update Filter Preview] button in the Search and Filter Options window has 
been changed to [Update] to avoid confusion about filters. Since filters are always 
precalculated regardless whether the filter preview (marked with yellow X’s) is enabled or 
not, these options are applied to the filters. To view this change, in MBMAX64 click Edit -
> Search and Filter Options, and view the different tabs. The MBMAX64 interface also 
uses “Filters” for the status labels instead of “Filter Preview”.

• When a project is created using HYPACK's Create New Project option, the Apply 
Grid Convergence checkbox in Sonar Processing dialog now defaults to checked. 
Previous default was unchecked.

When a project is created using HYPACK's Copy Existing option, the Apply Grid 
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Convergence checkbox will be checked or unchecked depending on the copy's source 
project, which is how this option has worked.

• The Save Survey window now detects and warns users if the selected data cannot 
be saved using the XYZ Selection / Save one Point per Cell options. When an invalid 
Save One Point per Cell situation is detected, the following warning appears.

ADCP PROFILE

• The Save to XYZ option has been added to the ADCP Profile program. Users can 
now directly output XYZ bathymetry data from All format files, ADCP files (*.ADP, *.000), 
and SonTek files (*.YDFF, *.RIV, and *.RIVR).

To us this new feature:

1. From the HYPACK Shell click Utilities -> ADCP -> ADCP Profile.
2. Load your data files by clicking File -> Open.
3. In the ADCP Profile window, click File -> Save to XYZ. The Select Folder for Export 

window appears.
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4. Click on the folder name where you want to save files to, then click [Select Folder].

All XYZ files are now saved to the selected folder.

PROCESSING OTHER DATA TYPES

MAGNETOMETER EDITOR

• Added the Fast Delete and Delete Interpolates checkboxes to Magnetometer Editor 
window.

> Fast Delete - When this option is checked, data selected with the Lasso Select, Block 
Select or Line Select tools is automatically deleted according to your Inside/Outside 
and Above/Below selections.

> Delete Interpolates - When you delete a position or value, it will delete the selection 
items and replace them with an interpolated value based on the items before and 
after the selection.

• The following keyboard shortcuts are now available to use in the Magnetometer 
Editor:
> Arrow keys: Advance data cursor.
> A: Delete Above, B: Delete Below, I: Delete Inside, O: Delete Outside
> M: Measure Tool, L: Line Select, S: Lasso Select, T: Block Select, D: Fast Delete On/

Off.
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DATA CONVERTER

Updated the settings dialog in the HSX Converters program for Reson S7K files to 
include an option for No Downsampling of the data when using HYSCAN Beta.

FINAL PRODUCTS

HYPLOT MAX
• Users can now zoom to where individual project files appear on the map area. If a 

project file in the Charts (Map Area) section on the right is enabled and highlighted in 
blue, right click on it and select the Zoom Extents option.

> Any enabled item may be right clicked to reveal the option, but the item highlighted in 
blue will be focused.

> This action may only be performed on individual items, not on categories or groups of 
multiple items. For groups of items, use the Zoom Extents button on the top bar.

TIN MODEL

• Added the Single Beam Depths option to the Initial Data window. This option only 
displays for files with single beam data. When loading edited log or HS2x files, you can 
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choose to load Depth 1, Depth 2, or All Depths.

To select the Single Beam Depths you want to use when building your TIN model:
1. From the HYPACK Shell, click Final Products -> TIN Model. The TIN window opens.
2. In the TIN window, click File -> New. The Initial Data window appears. 
3. Click [Main Input File] and select your single beam edited log (*.EDT) or HS2x files. The 

Single Beam Depths option is available if you selected single beam data.
4. In the remaining fields, enter any additional files needed for your output goal.
5. Select Depth 1, Depth 2, or All Depths from the dropdown, then click [OK] to generate the 

TIN model.

ENC EDITOR

• Removed the Geodesy option from the Environment drop down menu since this 
executable is no longer linked in the ENC Editor. Instead, set the geodesy from the 
HYPACK Shell by clicking Preparation -> Geodetic Parameters.

Previous (left) and current (right) versions of the Environment drop down menu

UTILITIES

NEW TOOL: ABSOLUTE OCEAN INTEGRATOR

HYPACK now offers integration with Terradepth's Absolute Ocean (AO) platform, 
which is a cloud-native platform that allows users to manage, visualize, and 
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collaborate on ocean data. Now, cloud processing is enabled through the AO partnership 
with HYPACK software.

For full information on this integration, refer to the article Absolute Ocean Integration with 
HYPACK® by Jocelyn Kane, published October 2024. A case study, workflow Q&A, and 
workflow brochure on the integration of HYPACK® and Absolute Ocean will also be released 
this month.

Here is a quick overview:

• To use the new Absolute Ocean integration, open HYPACK®, and from the HYPACK 
Shell, click Utilities -> File Work -> Absolute Ocean Integrator. The Absolute Ocean 
Integrator dialog opens.

• The tool displays the HYPACK project folder and file structure on the left, and the right 
side displays the currently selected AO project and all files within it.

• Within the file structures, each row will have a checkbox to select or deselect the item.
• Click [Upload] to upload all selected HYPACK project files to the selected AO project.
• Click [Download] to download all AO project files to the selected HYPACK project.
• Click [Synchronize] to search for differences in files. Where there is a difference, the 

newer file will be uploaded or downloaded.
• Check the Auto Synch checkbox to continuously search for new files in your HYPACK 

project that do not exist on the AO server and upload them, and search for new files on 
the AO server that do not exist in the HYPACK project and download them.

• Log in to your AO account from the bottom. Check the Login on Startup checkbox to save 
your login credentials, to automatically log into your AO account when you open the 
Absolute Ocean Integrator.

DATA CONVERTER

• Added the On Towfish checkbox to the ...To HSX tab in the HYPACK HSXConverter 
window. While checked, any HSX files generated from JSF files will have draft values, 
which are read in MBMAX64 when the converted HSX file is opened.
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To use this new feature:
1. From the HYPACK Shell, click Utilities -> File Work -> Data Converter. The HYPACK 

HSXConverter window appears.
2. Navigate to the ...To HSX tab and click [Setup]. The Settings window appears.
3. In the Settings window for the Edgetech JSF Setup, check the On Towfish checkbox to 

enable the pressure or depth values parsed from the JSF to serve as the draft values that 
are read from the HSX file in MBMAX64.
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