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HYPACK SHELL

• In the Project Items list, the right-click menu options have been reorganized to 
group related items. Some items were also moved to the Options menu drop down to 
reduce the volume of options in right-click pop up menu.
The following images are examples of what the right-click menu looks like before (left) 
and after (right) the update.

• Added the options Export to XYZ and Export to MTX to the right-click menu for 
ESRI TIF files. Access the menu from Project Items list in the HYPACK Shell.
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> If Export to XYZ is selected, the Save As window appears. Give the XYZ file a name 
and click [Save]. The file is saved to the Sort folder by default.

> If Export to MTX is selected, the Save As window appears. Give the MTX file a name 
and click [Save]. The file is saved to the project folder by default.

• Added yards to the list of selectable units in the units drop down of the Measure 
Tool.
To use this new feature, in the HYPACK Shell, click the Measure tool on the right toolbar.
The distance and azimuth toolbar appears at the bottom of the Map window. Click the 
units drop down and select yards.
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PREPARATION

GEODETIC PARAMETERS

• The Datum Shift File field in the Geodetic Parameters dialog has been changed to a 
dropdown list that contains only valid datum shift files (*.lls and *.gsb).

HARDWARE

SURVEY DEVICE DRIVER UPDATES

• New Driver: Optimal Ranging Orion (Orion2.dll)
This driver is largely identical to the Orion.dll driver and was created for a specific use 
case that may not be relevant to all users. This driver uses the Orion ROV's position, 
depth, and heading to calculate the position and depth of burial of a target cable. The 
measured depth can then be corrected in SBMAX using altitude data from an altimeter. 
The following is a list of where the drivers differ:
> The Orion2 driver additionally reports position, depth, and heading. This driver uses 

the USBL position and depth as a starting point, then uses the current offset from the 
device to obtain its position and depth. The heading can be configured to come from 
the Orion device itself or from the USBL.

> To work properly, this driver requires an altimeter and must be on its own mobile with 
a gendevparse.dll driver reading heave from the altimeter. The Orion2 driver should 
be set relative to another ROV mobile which handles the position of the device itself.
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> The heave and depth data should be used in SBMAX to calculate the depth of burial 
of a target cable.

> The following setup parameters allow the data to be easily read by SBMAX:

• DQM Mechanical Driver (DQM_Mechanical.dll)
Added CD17 Système to the DQM_Mechanical driver, which acts as a ModBus 
master to obtain crane slew, boom angle, and wire length from the sheave. Select 
this option if you have a ModBus-connected PLC crane. Note that the modbus.dll needs 
to be added to the HYPACK 2024 root directory to support the ModBus connection.

To use this feature:
1) From the HYPACK Shell, click Preparation -> Hardware Setup to open the HYPACK 
Combined Hardware window.
2) Add the DQM Mechanical Driver, and double click it to open the Settings window.
3) Under the System Type drop down menu, select CD17 Système. The CD17 Système 
tab appears.
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4) Under the CD17 Système tab, fill out the IP address of the PLC crane, the ModBus port 
number, and the holding register offset.

• MAVLink (mavlink.dll)
The MAVLink driver setup window has been completely reworked - The Upload Mission 
and Download Mission buttons have been replaced with a dropdown to select the 
manufacturer. The current manufacturer options are Generic and Seafloor USV.

This change was made because both Upload and Download Mission buttons are now 
redundant, as we upload the current Survey line file to the device when you click the 
[Start Mission] button in Survey. The Download Mission button could have some utility if 
you were trying to transfer Survey line plans using your vessel, but there are better ways 
to do that and limited use cases.
For more information about the MAVLink driver update, check out the article MAVLINK 
Autopilot Updates by Daniel Tobin, published October 2024.

Before After
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INPUT ECHO

The Input Echo dialog has received multiple updates.

• Users can now add and remove up to eight outputs using the newly added [Add Output] 
and [Remove Output] buttons.
> The supported output connection options are serial port, parallel port, and network 

port. Additionally, the output data can also be saved to file(s).
> If the wrong device is removed, click [Add Output] to add back the most recent 

deleted device.
• The supported input port types are serial port, parallel port, and network port.
• Parameters change depending on the input or output connection type selected.
• When File is selected as the output connection type, check the Split Files checkbox to 

split the data into multiple files based on size. This prevents giant files from being 
created. Additional files will be saved in the format {FileName}_{number}.extension (Ex: 
test.tmp, test_1.tmp, test_2.tmp, etc.).

• Settings are saved when Input Echo is closed.

TARGETS

TARGET EDITOR

• Klein Spectral AI targets can now be imported in the Target Editor.

To use this new function:
1. From the HYPACK Shell, click Preparation -> Editors -> Target Editor. The Target Editor 

window appears.
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2. In the Target Editor window, click File -> Import -> Klein Spectral AI. The Import Target 
File window appears.

3. Select one or multiple Klein Spectral AI target files and click [Open]. Only JSON files can 
be selected. The associated TIF file will also be imported as well.

Back in the Target Editor, the selected Klein Spectral AI targets will appear in the list of 
targets on the left. Name and metadata read from the JSON file of the associated target 
will be displayed on the right, as well as the TIF image.

SURVEY

HYSWEEP SURVEY
• Added the Dredge Mode option to the Matrix Options window in HYSWEEP Survey. 

Enable Dredge Mode if the vessel is stationary (dredge conditions). This fills the real time 
matrix with values that have applied offsets appropriate to a stationary dredge as 
opposed to a moving survey boat. Soundings are filtered via signal strength and 
collinearity to determine and select the highest quality soundings for use in the matrix.

With Dredge Mode enabled, roll, pitch, and non-averaged tide corrections are 
automatically applied to the matrix values, but not heave. While Dredge Mode is enabled, 
the Draw Matrix in HYPACK Survey option is permanently enabled as well.

To use this new option:
In the HYSWEEP Survey window, click Options to open the Matrix Options window and 
check Dredge Mode. A couple of things will happen.
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The title bar of "HYSWEEP Survey" will be replaced with "HYSWEEP Dredge Mode".

The View Options window (HYSWEEP View -> Options -> Other tab) will also 
permanently enable the Apply Heave, Pitch, Roll Corrections and the Apply Tide 
Correction options while Dredge Mode is selected.

• Added the Invert Depths option to the Matrix Options menu, which inverts the 
depth values going into the matrix. This is for users who need an elevation matrix/
elevation mode.

• In the View Options dialog, when Auto Scale Profile is checked, the minimum depth 
value (z-axis) is now automatically updated for the Sweep Profile and the Sounding 
Points options. Note that the minimum depth value remains locked at zero for the Beam 
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Pattern and Wavefront options.

To use this feature:
1. In HYSWEEP Survey, click View -> Options. The View Options dialog appears.
2. In the Multibeam Display tab, check Auto Scale Profile, select either Sweep Profile or 

Sounding Points, and click [Apply].

You will see that the minimum depth value automatically adjusts to a more suitable value 
in both the Ranges tab of the View Options dialog, as well as the Profile Window.

POST-PROCESSING

64-BIT SINGLE BEAM EDITOR (SBMAX64)
• Added the Hide Deleted checkbox to the Spreadsheet window, which hides deleted 

soundings when checked. The first image below shows deleted soundings in the 
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Spreadsheet window while Hide Deleted is unchecked, and the following image shows 
the spreadsheet with deleted soundings removed after Hide Deleted is checked.

• The tide displayed in Tide Analyzer now matches with the Tide shown in the Heave/
Tide/Draft Editor window in SBMAX64. Previously, the tide display was inverted.
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• Added the field Z-Multiplier for XYZ to the Save Survey window. Users can now enter 
a positive or negative value, which will be used as a multiplier with the Z value. For 
instance, enter -1.0 to invert the Z. The default value is 1.0.

To use this function:
1. In SBMAX64, click File -> Save Survey. The Save Survey window appears.
2. Type the multiplier value in the Z-Multiplier for XYZ field.
3. Select one of the save options, and the Save As window appears. Keep in mind the XYZ 

files are saved in the project's Sort folder by default.
4. Give the XYZ file a name and click [Save].
5. Open the XYZ file and verify that the Z multiplier has been applied.

The following example images below show the XYZ values without (left) and with (right) 
the multiplier of -2.0 applied.
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64-BIT HYSWEEP EDITOR (MBMAX64)
• When a project is created using HYPACK's Create New Project option, the Apply 

Grid Convergence checkbox in Sonar Processing dialog now defaults to checked. 
Previous default was unchecked.

When a project is created using HYPACK's Copy Existing option, the Apply Grid 
Convergence checkbox will be checked or unchecked depending on the copy's source 
project, which is how this option has worked.

FINAL PRODUCTS

HYPLOT MAX
• Users can now zoom to where individual project files appear on the map area. If a 

project file in the Charts (Map Area) section on the right is enabled and highlighted in 
blue, right click on it and select the Zoom Extents option.

> Any enabled item may be right clicked to reveal the option, but the item highlighted in 
blue will be focused.

> This action may only be performed on individual items, not on categories or groups of 
multiple items. For groups of items, use the Zoom Extents button on the top bar.
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UTILITIES

NEW TOOL: ABSOLUTE OCEAN INTEGRATOR

HYPACK now offers integration with Terradepth's Absolute Ocean (AO) platform, 
which is a cloud-native platform that allows users to manage, visualize, and 
collaborate on ocean data. Now, cloud processing is enabled through the AO partnership 
with HYPACK software.

For full information on this integration, refer to the article Absolute Ocean Integration with 
HYPACK® by Jocelyn Kane, published October 2024. A case study, workflow Q&A, and 
workflow brochure on the integration of HYPACK® and Absolute Ocean will also be released 
this month.

Here is a quick overview:

• To use the new Absolute Ocean integration, open HYPACK®, and from the HYPACK 
Shell, click Utilities -> File Work -> Absolute Ocean Integrator. The Absolute Ocean 
Integrator dialog opens.

• The tool displays the HYPACK project folder and file structure on the left, and the right 
side displays the currently selected AO project and all files within it.

• Within the file structures, each row will have a checkbox to select or deselect the item.
• Click [Upload] to upload all selected HYPACK project files to the selected AO project.
• Click [Download] to download all AO project files to the selected HYPACK project.
• Click [Synchronize] to search for differences in files. Where there is a difference, the 

newer file will be uploaded or downloaded.
• Check the Auto Synch checkbox to continuously search for new files in your HYPACK 

project that do not exist on the AO server and upload them, and search for new files on 
the AO server that do not exist in the HYPACK project and download them.

• Log in to your AO account from the bottom. Check the Login on Startup checkbox to save 
your login credentials, to automatically log into your AO account when you open the 
Absolute Ocean Integrator.
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